Content Hub Assets not showing

Incident Report for Amplience

Postmortem

10/09/25

Incident Start Time: 15:06 BST

Incident End Time: 15:20 BST

 

11/09/25
Incident Start Time: 12:09 BST

Incident End Time: 12:15 BST

 

Issue Summary:

On 10th September, we experienced a brief outage within our Content Hub platform. Assets were no longer displaying in the UI, and some background processes that relied on indexing failed to run to completion. The following day, we experienced the same outage - we had fixed the issue initially, but not all of the corrective actions had been completed. 

We’d like to point out that this short outage did not impact any published assets. 

Root Cause:


We identified that an unindexed query over time caused an excessive consumption of memory in our backend platform, Solr. 

 

‌Corrective Actions:

  • Operations were able to cycle the Solr nodes to clear the memory utilisation.
  • The Solr memory in the backend has been increased.
  • Additional monitoring and alarms have been enabled to identify cache entries before memory is fully consumed.‌

If you have any questions or would like to discuss this further, please reach out to your Customer Success Manager or contact us at csteam@amplience.com.

Posted Sep 12, 2025 - 11:39 BST

Resolved

This incident was resolved at 15.20 BST
Posted Sep 10, 2025 - 15:36 BST

Monitoring

We have identified the root cause and assets now return in Content Hub.
Posted Sep 10, 2025 - 15:20 BST

Investigating

We are currently investigating.
Posted Sep 10, 2025 - 15:16 BST
This incident affected: Content Hub.